You are not logged in or registered. Please login or register to use the full functionality of this board...

Automotive Diagnostic Tool

Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DiagBox 8.xx Installation & Upgrade
11-12-2017, 02:56 PM (This post was last modified: 11-13-2017 01:45 AM by manocao.)
Post: #31
RE: DiagBox 8.xx Installation & Upgrade
Hi Simple, is it possible to apply you 8.xx installation method with this psa original diagbox 8.41 installer instead of with 8.01 installer, or it is not possible to skip online activation?


Attached File(s)
Diagbox 8.41 original installation.txt
File Type: .txt
Downloaded: 151 times
Size: 70 bytes


manocao, proud to be a member of GarageForum since Dec 2015.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-12-2017, 03:45 PM
Post: #32
RE: DiagBox 8.xx Installation & Upgrade
(11-12-2017 02:56 PM)manocao Wrote:  Hi Simple, is it possible to apply you 8.xx installation method with this psa original diagbox 8.41 installer instead of with 8.01 installer, or it is not possible to skip online activation?
https://mega.nz/#!1o90QKTZ!ddeABTfFukUaV...KSI4k481LY
Editing the files would require access to the same original setup in order to obtain some encrypted configuration files. Regrettably I don't have access to such!!

Simple, proud to be a member of GarageForum since Dec 2014.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-13-2017, 01:39 AM (This post was last modified: 11-13-2017 01:54 AM by manocao.)
Post: #33
RE: DiagBox 8.xx Installation & Upgrade
i tried:
after applied Kill_DiagBox_Tasks.bat and AWRoot_v7_Conf+Ativation_v8.exe, i run diagbox and get this error:
not found entry point xxx in such .dll
[Image: attachment.php?aid=3728]
then i replace xmltracegenu_vc80.dll with diagbox 7's, error disappear but it comes this new error:
[Image: attachment.php?aid=3729]
no matter changes i do with the files that AWRoot_v7_Conf+Ativation_v8.exe replaced, or leaving original files like awfinterpreter_vc80.exe... no success.
at a time, it reached diagbox 8.41 main screen but reported error of, i think to remember, 'security file missing', and 'it must close down' (forgot to capture screen)
maybe a new AWRoot_v7_Conf+Ativation_v8.exe is what's needed


Attached File(s) Thumbnail(s)
       

manocao, proud to be a member of GarageForum since Dec 2015.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-13-2017, 02:35 AM
Post: #34
RE: DiagBox 8.xx Installation & Upgrade
You will get similar problems even if you apply any update, changes to the structure or the function will be referenced in some encrypted files which you cannot easily recreate.

However, if you have access to a working (dealer) installation, you may borrow these files and try injecting them in your compilation. But even then, it is a very time consuming process..

Simple, proud to be a member of GarageForum since Dec 2014.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-16-2018, 01:01 AM
Post: #35
RE: DiagBox 8.xx Installation & Upgrade
Hi,
I have successfully installed v8.01. but when I go into the program it shows error for "Data access problem".
Help anyone??

hoooigai, proud to be a member of GarageForum since Jan 2018.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-18-2018, 06:19 AM
Post: #36
RE: DiagBox 8.xx Installation & Upgrade
I really can't get it to work.

OS Windows 10 64 bit running Virtualbox 5.2.6. I Built the virtualmachine on a Windowd XP VHP file directly from MS. I installed .NET3.5sp1 and VC2008++. I installed the Deamon tools. Guest additions are installed as is the addon for USB2 and 3 support. I used the commandprompt to insert my serial into the Virtualbox as described. All worked.
I can install Diagbox + updates (now at 7.58). And the software runs with no error messages.

If I run the PSA Interface Checker in Windows 10, I can acces the cable. I have a Rev C Full chip and I could update firmware from 4.2.8 to 4.3.2 (the latest I had). But how do I get Virtualbox to show me that cable. PSA Interface Checker does nothing. If I look under USB, I see a PSA device (my cable?). Do I install the Lexia drivers in Windows 10 or not.

Who can help me out?

Koezt, proud to be a member of GarageForum since Jan 2018.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-19-2018, 03:57 AM (This post was last modified: 01-19-2018 03:58 AM by Simple.)
Post: #37
RE: DiagBox 8.xx Installation & Upgrade
(01-18-2018 06:19 AM)Koezt Wrote:  I really can't get it to work.

OS Windows 10 64 bit running Virtualbox 5.2.6. I Built the virtualmachine on a Windowd XP VHP file directly from MS. I installed .NET3.5sp1 and VC2008++. I installed the Deamon tools. Guest additions are installed as is the addon for USB2 and 3 support. I used the commandprompt to insert my serial into the Virtualbox as described. All worked.
I can install Diagbox + updates (now at 7.58). And the software runs with no error messages.

If I run the PSA Interface Checker in Windows 10, I can acces the cable. I have a Rev C Full chip and I could update firmware from 4.2.8 to 4.3.2 (the latest I had). But how do I get Virtualbox to show me that cable. PSA Interface Checker does nothing. If I look under USB, I see a PSA device (my cable?). Do I install the Lexia drivers in Windows 10 or not.

Who can help me out?
No drivers need to be installed on the Host (Windows 10). A USB device can only be read by the Host system or Pass Trough to the Guest. it can be hooked by one operating system, either the Host (windows 10) or the Guest (Windows XP), but not both in the same time.

Your issue seems that the VCI is not picked up by the Guest (Windows XP) as a USB device, or the drivers are not installed properly on the Guest (Windows XP).

However, ensure that VirtualBox_Extension_Pack is also installed on Host (Windows 10).

There are 2 ways of adding a USB device to VirtualBox:

1- If you click on the USB icon with round green dot to add a device, this will make the guest Windows recognise and connect any USB device, all what you need is to install the drivers (if not recognised) on the Guest (XP in your case) to be fully recognised.

2- If you click the Add USB icon with green plus to add a device, it will list available/connected USB devices (Camera, Card Reader, USB memory, VCI etc..). The device you choose here will ONLY be passed through to the guest Windows, you still need to install drivers if it is not fully recognised.

If a USB device (like a memory stick) is read by the Guest Windows, it will not be seen by the Host Windows until you disable (uncheck) USB or shutdown guest Windows.

Simple, proud to be a member of GarageForum since Dec 2014.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-19-2018, 04:31 AM
Post: #38
RE: DiagBox 8.xx Installation & Upgrade
Solved it! It turned out that you need to run Virtualbox as administrator, not just under an administrator account...

Once I set that, guest os detected a new device and bingo. Due to the time yesterday I took it to the car only to see if I had comms. And it read my vin number, so I guess that's sorted.

Now for that trailer hitch module... I'll look into that this afternoon.

Koezt, proud to be a member of GarageForum since Jan 2018.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-19-2018, 05:35 PM
Post: #39
RE: DiagBox 8.xx Installation & Upgrade
HI guys. Im not new here only forgot my old password. (wasnt using forum that mutch Sad )
Can you please give me a link where can i start to download a DiagBox 7? and patches for it?!!
I all ready have 7.53 on my laptop, witch i downloaded here couple of years ago. But it's not working properly.
Thanks all..

Dinko, proud to be a member of GarageForum since Feb 2018.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)